A try at a Hammond XB2 repair

MatevĹľ brought me a new organ to try to repair – Hammond XB2 🙂 It was lent to him by the original owner to decide whether to buy it or not. Here is a sample of how it sounded (not right at all):

Actually the synthesiser seemed to work to a certain (pretty low) volume level correctly, but at a higher volume level started producing clicking / buzzing / overdrive noise. The problem was getting worse by lowering tones and making the volume higher.

My initial suspicion was that something in the analog amp / mixing section (shown below) was causig the overdrive effect.

IMG_20150523_182634971

We tracked the signal from the audio output jack to the corresponding DAC, however we were unable to find where the distrortion started – it seemed that the DAC was already giving out a distrorted signal. This was confirmed when we disconnected the analog section altogether and measured the signal at the output of DAC.

The Hammond XB2 has two identical DAC chips, but they are responsible for different things. One is located on the mainboard and the other one is on its own board. To access the DAC on mainboard and connector to the second DAC you have to temporarily remove the MIDI input/output board shown below. The connectors are otherwise hidden under it.

IMG_20150523_182623985

Conveniently signals to drive both of the DAC-s are all available on the connector for the separate DAC. The DAC that was misbehaving was the one present on the mainboard. The offboard DAC was rewired (easily done using dupont cables) to the same signal the onboard DAC was receiving, to see if maybe the DAC chip itself was at fault.

IMG_20150523_184045316Unfortunately after rewiring both of the DACs were showing the same behaviour so we could rule out DAC fault.

IMG_20150523_184056167

We also probed a bit around the digital signals using oscilloscope to see if there were any obivous signal integrity issues, but couldn’t find any. Most probably the digital signal coming from the Muse chip already contained the distrorted information.

We had to decide either to buy and try to repair the organ or to return it to the original owner. Unfortunately I think the problematic component is the Muse chip itself, which is not easily available (probably as scarce as old Hammond organs these days). If we had additional time we could use oscilloscope and logic analyzer on the DAC and Muse RAM signals to try to reverse-engineer the data streams – maybe there is just a failing connection somewhere on the PCB or the RAM is failing after the years in use…

Well, the organ works as a MIDI keyboard at the moment, but what we would really like to see is its synthesiser working again 🙂

4 comments on “A try at a Hammond XB2 repair
  1. Josu says:

    Any progress on that?

    • dejko1 says:

      Well, currently the keyboard is still used as is (as a midi keyboard) with external Yamaha synthesizer. We may try to replace Muse RAM somewhere in the future, but it is not really on the high priority list…

  2. vittoles says:

    Hi
    do you have eprom V2 or hex files to burn 27V256?
    best regards.

  3. vittoles says:

    Hi do you have the hex files or eprom V2 for an XB-2?
    regards.

Leave a Reply to vittoles Cancel reply

Your email address will not be published. Required fields are marked *

*